בעיה בקידוד

פורום התמיכה לגרסה phpBB2. שימו לב - פורום זה הינו פורום ארכיון. התמיכה במערכת phpBB2 הופסקה.

מנהל: צוות האתר

mischel
משתמש חדש
משתמש חדש
הודעות: 16
הצטרף: 30/01/2006 ב-06:30:23

בעיה בקידוד

הודעה שלא נקראהעל ידי mischel » 07/08/2008 ב-17:05:38

סוף סוף הצלחתי לבנות פורום (ישן - phpBBHeb) על השרת החדש ולהעביר אליו את הפורום שהיה על השרת הישן.

הבעיה היא שהפורום החדש נראה משובש - ריבועים במקום אותיות, אבל כאשר לוחצים על קידוד -> עברית באקספלורר אז הוא נראה בסדר ואפשר לקרוא אותו ולכתוב אליו.
הבעיה חמורה מאד כיוון שבהעלאת כל דף חדש הפורום עולה משובש - בוחר ב-utf8 וזה למרות שהאקספלורר שלי מככוון לעשות קידוד -> בחירה אוטומטית.

קראתי את העצות בפורום לגבי המרה ל-utf וניסיתי לעשות המרה הפוכה מ-utf, ושיניתי בקבצים
language/lang_hebrew/lang_main.php
templates/subSilver/overall_header.tpl
את ה-content type ל-windows-1255 וגם זה לא עזר.

מה אפשר לעשות כדיי שהפורום יעלה אוטמטית בקידוד הנכון?

תודה,
מיכל

Berlo
חבר צוות phpBB ישראל לשעבר
חבר צוות phpBB ישראל לשעבר
הודעות: 2393
הצטרף: 11/12/2004 ב-21:59:20
יצירת קשר:

Re: בעיה בקידוד

הודעה שלא נקראהעל ידי Berlo » 07/08/2008 ב-19:06:46

לתת קישור.
Berlo

mischel
משתמש חדש
משתמש חדש
הודעות: 16
הצטרף: 30/01/2006 ב-06:30:23

Re: בעיה בקידוד

הודעה שלא נקראהעל ידי mischel » 07/08/2008 ב-21:11:00


Berlo
חבר צוות phpBB ישראל לשעבר
חבר צוות phpBB ישראל לשעבר
הודעות: 2393
הצטרף: 11/12/2004 ב-21:59:20
יצירת קשר:

Re: בעיה בקידוד

הודעה שלא נקראהעל ידי Berlo » 07/08/2008 ב-22:31:48

נראה כאילו נשלחים HEADERS מהשרת, עוד לפני הגעת ה-HTML, שמודיעים על CHARSET מסוג UTF8.

אם יורשה לי: לשם מה את זקוקה לפורום הישן?
מדוע פלא פשוט להמיר כעת לפורום החדש?
Berlo

mischel
משתמש חדש
משתמש חדש
הודעות: 16
הצטרף: 30/01/2006 ב-06:30:23

Re: בעיה בקידוד

הודעה שלא נקראהעל ידי mischel » 08/08/2008 ב-07:39:18

הי ברלו,

הסיבה שהתקנתי את הפורום הישן היא שרציתי לשמור על הנתונים הישנים, והפורום החדש מסוגל להמיר רק מפורום שיש לו path יחסי אליו, ולכן התקנתי את הישן ב-path דומה לחדש וקיוויתי להמיר אותו לחדש, אבל זה הסתבך ובינתיים לא הצלחתי להמיר.
אני אמשיך לנסות כי אני רוצה לעבור לחדש.
יתכן שהבעיות בהמרה לפורום החדש נובעות גם המותן סיבות שהישן לא עובד (כי בהמרה לחדש כן נוצרו טבלאות ב-mySQL קר שהפונטים בהן משובשים!)

בכל אופן כנראה שהשרת הישן שלי (מאד ישן windows 2003) עומד לקרוס, אז חשוב לי שיהיה קודם לפחות פורום אחד שעובד - חדש או ישן על השרת החדש.

לא הבנתי איך נשלחים headers מהשרת לפני שליחת הדף, אפשר לבטל את זה?

תודה,
מיכל

Berlo
חבר צוות phpBB ישראל לשעבר
חבר צוות phpBB ישראל לשעבר
הודעות: 2393
הצטרף: 11/12/2004 ב-21:59:20
יצירת קשר:

Re: בעיה בקידוד

הודעה שלא נקראהעל ידי Berlo » 08/08/2008 ב-09:27:50

לגבי HEADER:
http://il.php.net/header
אך זה מוזר לי כי לא אמור להיות קוד כזה ל-UTF8 למיטב זכרוני.

אני מציע שנתקדם בעניין השדרוג. לא חייב להיות PATH יחסי, ולמעשה אין צורך בקבצי הפורום כלל, רק בגיבוי בסיס הנתונים.
אני חושב שיש נקודה חשובה שלא הובהרה: בהמרת הפורום, מתקינים את גרסה 3 על אותו בסיס נתונים כמו הפורום הקיים - בצוקה רגילה, פורום חדש. בסיום תהליך התקנה, מבצעים תהליך "המרה".
Berlo

mischel
משתמש חדש
משתמש חדש
הודעות: 16
הצטרף: 30/01/2006 ב-06:30:23

Re: בעיה בקידוד

הודעה שלא נקראהעל ידי mischel » 09/08/2008 ב-20:00:49

תודה, מצאתי את זה! זה באמת בהגדרות של אפאצ'י.

אז בשביל הפעם הבאה שמישהו יתקל בבעיה הזו: צריך לשנות בקובץ httpd.conf את המשתנה AddDefaultCharset לפונט הרצוי.

ושוב תודה על כל העזרה!!

מיכל :D

סמל אישי של המשתמש
Ronny
מנהל ראשי
מנהל ראשי
הודעות: 646
הצטרף: 14/11/2004 ב-18:37:22
יצירת קשר:

Re: בעיה בקידוד

הודעה שלא נקראהעל ידי Ronny » 10/08/2008 ב-22:35:25

מיכל, שמח לראות שהסתדרת. תודה ששיתפת אותנו בפתרון שעבד לך :-)
בהצלחה עם הפורום המחודש 8)


חזור אל “תמיכה - ארכיון”

מי מחובר

משתמשים הגולשים בפורום זה: אין משתמשים רשומים ו־ 12 אורחים